Issues with payment service
Incident Report for Hive
Resolved
Good news! You may now use your Hive products as service has been restored. We are taking steps to try and prevent this issue from happening again. We apologise for any inconvenience that this may have caused you. As always, our customer care team is available at help@hivehome.com if you have further issues.
Posted about 1 month ago. Jun 04, 2019 - 11:01 UTC
Investigating
We are currently experiencing some issues with our payment service, please rest assured we are rectifying this as a priority
Posted about 2 months ago. May 30, 2019 - 14:38 UTC
This incident affected: HiveHome.com Website.